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1 INTRODUCTION 
 
This document is a quick guide to help you get started with Iddero Home Server. Detailed, step-by-
step instructions are provided on how to create and configure a simple installation project, and upload 
it to the Iddero Home Server in order to control and monitor a KNX-based installation. 
 
This guide assumes basic knowledge and familiarity with KNX® technology and the ETS® configuration 
software. 
 

2 IDDERO CONFIGURATION SOFTWARE 

2.1 Installation and First Steps 
 
If you have not done it yet, you should now install the Iddero configuration software. The configuration 
software can be downloaded free of charge from www.iddero.com. 
 
The first time you run the software, you will be asked to select language. Available options include 
“Español” (Spanish), “English”, and “Deutsch” (German). 
 
Next, the software will request an activation key. In order to obtain the activation key, please contact 
your distributor, or just contact Iddero directly by clicking on the link shown in the dialog box. 
 
 

 
 
 
 
Once the activation process is complete, the main application window will be shown. 
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At the top, the main menu is shown (File, Project, Programming, Configuration, and Help) along with a 
toolbar with quick access buttons. 
 
The main window is split in three different areas: 
 
- Project tree (A): Shows the project structure, including sections for general parameters, zones and 

pages, maps, scenes, time programs, security, logic functions, and more. 
 
- Address tree (B): Shows group addresses for this project, including both regular group addresses 

and internal group addresses. 
 
- Parameter area (C): When an item is selected in the project or address trees, this area will show 

any configurable parameters that are available for this item. 
 
 
 
 
 
 

A 

B 

C 
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3 IDDERO HOME SERVER CONFIGURATION 

3.1 Process Overview 
 
The Iddero Home Server configuration process can be split in the following tasks: 
 

• Select the product model 
• Create or import group addresses 
• Configure the navigation structure (maps, zones, and pages) 
• Configure visual components 
• Link group addresses and communication objects 

 
 
We will now walk through this process step by step, in order to show how to create a sample project 
where the Iddero Home Server will be used to control a single lamp, through a KNX-based dimmer 
actuator. 
 
We will assume that the KNX dimmer actuator in question implements at least the following 
communication objects: 
 

• One 1-bit communication object for switching the lamp on and off (address 1/1/1) 
• One 1-byte communication object for setting the brightness value (1/1/2) 
• One 1-byte communication object that holds the current brightness value (feedback) (1/1/3) 

 

3.2 Select the Product Model 
 
The first thing you need to do is select the specific product that will be used in the project. For this, first 
select the “Project” section in the project tree, then choose “Iddero Home Server” in the “System type” 
field in the parameters section. 
 
Once the Iddero Home Server is selected, a new “Image size” parameter will be enabled. This allows 
you to define the size of images to be used in the projects (maps and background images). 
 

3.3 Create or Import Group Addresses 
 
Although it is possible to define group addresses directly in the Iddero configuration software, it is far 
more common to import them from an existing ETS project. 
 
For this, you will first need to export the group addresses from the ETS software into a .esf file. 
 
 

 Note: 
When exporting group addresses, ETS will only include addresses which are linked to at least one 
communication object. 

 

Exporting group addresses from ETS3 
 
Please select File → Extract Data (e.g. OPC)... in the ETS software. A dialog box “Export Foreign 
Format” will pop up. Click on the “Export...” button next to the “Export to OPC Server” option, and 
choose a suitable location for the .esf file. 
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Exporting group addresses from ETS4 / ETS5 
 
Select Extras → Export OPC, and choose a location for the .esf file. 
 
 

 
 
 
 
 

1 

2 
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Importing group addresses from the Iddero configuration software 
 
In the Iddero configuration software, select Project → Import addresses... and open the .esf file you 
just generated. 
 
Once the group addresses have been imported, they will be shown in the address tree. 
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3.4 Configure the Navigation Structure 

General Concepts 
 
Navigation in the Iddero Home Server is based on the concept of “zones” and “pages”. 
 
Zones are groups of elements and devices (“components”) within the installation. A zone can 
represent a room in a house, an office, a department in a services building, or just a group of devices 
that do not necessarily share a physical location. However the concept of zones is typically associated 
to rooms within a house. 
 
Devices associated to each zone are in turn organized in one or more pages. Each page can show up 
to eight devices. The grouping of devices in pages can be done based on arbitrary criteria: Devices 
can be grouped by function, by type, by frequency of use, etc. 
 
In general, navigation in the Iddero Home Server works as follows: 
 

1. The user selects the target zone 
2. The user selects the target page within the zone, by touching the corresponding icon in the 

navigation bar 
3. The user operates the target device (component) in the page 

 
 
The following screenshot shows the structure of a typical page with six devices. The navigation bar at 
the top of the screen shows that this page belongs to the “Living room” zone, and that the zone 
includes another two pages besides the one shown. 
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In our sample project we will initially create one single zone with one single page, since we only need 
to control one device. 
 
In a real-world project, though, the navigation structure should be carefully planned so that navigation 
is as easy and comfortable as possible for the end user. 
 

Definition of zones 
 
In order to add a zone to the project, right-click on the “Zones and pages” section in the project tree, 
and select “Insert zone” from the pop-up menu. 
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By selecting the newly inserted zone (left-click on the new zone in the project tree, or double-click on 
the zone name in the table shown in the parameter area) the configurable parameters will be shown. 
 
In this case, the only parameter that can be configured is the zone name. Set this to “Living room” for 
this zone. 
 
 

 
 
 

Definition of Pages 
 
In order to add a page to a zone, right-click on the zone in the project tree, and select “Insert page” 
from the pop-up menu. 
 
By selecting the newly created, the configurable parameters will be shown in the parameter area: 
 
- Name: A descriptive name for this page. 
 
- Icon: The icon that will be shown for this page in the navigation bar. 
 
- Component count: Determines how many components will be shown in this page. 
 
- Access level: The minimum access level that is required in order to access this page. 
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Since our page will be used for lighting control, you can just leave the default icon (a light bulb). 
 
There will be one single device in this page. Thus, select “1” in the “Component count” parameter. A 
component will automatically be added beneath the current page in the project tree. We will take care 
of its configuration in the following section. 
 
You can also leave the “Access level” parameter to its default value (“Not restricted”). 
 
 

Definition of Maps and Active Areas 
 
In order to make it easier for the end user to navigate through available zones, you can define image-
based maps as well as “touchable areas” that can be linked to zones or to other maps. 
 
 

 Note: 
Map definition is optional. If no maps are defined, the system will just present a list of available zones to 
the end user. 

 
 
In order to insert a new map, right-click on the “Maps” section in the project tree and select “Insert 
map” in the pop-up menu. Then, just select the newly added map and the configurable map 
parameters will be shown in the parameter area. 
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Next step is to pick a background image for the map. 
 
Background images can be created using any drawing or picture editing software, or with specialized 
CAD and 3D design packages. 
 
Once you have your background image ready, click on the “Open...” button in the map configuration 
section, and select the image file. GIF, JPEG, and PNG file formats are supported. If the image size is 
larger than the image size currently selected for this project, the image will be adapted (trimmed) to 
the right size automatically. 
 
 

 
 
 
Now we will define one active (“touchable”) area on top of the image. 
 
Right-click on the map in the project tree, and select “Insert area” from the pop-up menu. Then, select 
the newly created area in the project tree. 
 
Assign a descriptive name for the area (for example, “Living room”). Then, in the “Target” combo box, 
select the “Living room” zone. By doing this, we are specifying the zone that should be opened when 
the user touches this area on the map. 
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Now, the polygon associated to this touchable area must be defined. Click on the “Add points” button, 
then click on the image to add the vertices for the polygon. 
 
The “Delete points” and “Move points” buttons let you delete and move existing polygon vertices. 
 
 

 
Note: 
You can use the mouse wheel to zoom in and out of the map. While zoomed in, hold down the middle or 
right mouse button and drag the mouse to pan the image. 
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3.5 Configure Visual Components and Link Group Addresses 
 
We will now configure the visual component that will be used to control the lamp from the Iddero 
Home Server. As described earlier, we will actually be controlling this lamp through a KNX-based 
dimmer actuator. 
 
Select the component beneath the first page of the “Living room” zone. Set a descriptive name, for 
example “Dimmable lamp L1”, and choose “Lamp control” from the “Type” combo box. 
 
The dimmer actuator in our sample project implements a 1-byte communication object that can be 
used to set the brightness (light intensity) value. This is often referred to as absolute dimming. Thus, 
you should check the “Enable Value object” checkbox. However, leave “Enable dimmer control object” 
unchecked (this one refers to the 4-bit object used for relative dimming). 
 
Finally, in the “Status objects” combo box, select “1 byte” since our dimmer actuator provides a 1-byte 
communication object that indicates the current brightness status. 
 
If you look at the project tree, you will see that several communication objects have automatically been 
added under the “Dimmable lamp L1” component: One 1-bit communication object (“Switching object”) 
and two 1-byte communication objects (“Brightness value” and “Lamp status (dimming value)”). 
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The Iddero Home Server will send On and Off telegrams to the first of these communication objects, 
absolute brightness values to the second one, and will use the value of the third object in order to 
update the graphical representation of the lamp’s status. 
 
Group addresses must now be linked to communication objects. First, link group address 1/1/1 
(“On/Off”) to the lamp’s Switching object. This is done through a drag & drop operation: Click and hold 
the left mouse button over the “On/Off” address node in the address tree; then, without releasing the 
mouse button, drag the address onto the communication object in the project tree; finally, release the 
mouse button. 
 
Repeat this operation with the Brightness value and Lamp status objects, and link them with group 
addresses 1/1/2 “Brightness (value)” and 1/1/3 “Brightness (status)”, respectively. 
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If you select any communication object in the project tree, the parameters area will show any linked 
group addresses, along with the current configuration of the communication object’s flags (these flags 
define the behaviour of each communication object regarding telegrams sent to and received from the 
bus. Please refer to the KNX standard for the detailed meaning of each flag). 
 
Likewise, if you select any group address in the address tree, the parameters area will show any 
linked communication objects. 
 
 

 
 
 

3.6 Save the Project 
 
Save the project if you have not done it yet (File → Save). We can then move on to the commissioning 
process. 
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4 INSTALLATION AND COMMISSIONING 

4.1 Installation 
 
The Iddero Home Server is a compact unit suitable for 35mm DIN-rail mounting. It is typically installed 
on an electrical cabinet, along with the provided 12 VDC power supply unit. The product datasheet 
provides additional installation instructions. 
 
During the installation process, the following connections should be made: 
 

• Power supply (12 VDC). Only the provided power supply should be used. 
• KNX bus 
• Ethernet network 
• RS-485 bus, if an expansion module such as the DW-GSM will be used 

 
 
 

 Note: 
In most cases, the Iddero Home Server will be connected to a local network through a hub or switch. In 
this case, a straight (1:1) Ethernet cable should be used. However, in some situations you may want 
to connect the Iddero Home Server directly to a PC or notebook, without using a hub or switch (for 
example for configuration and commissioning). In this case, use a crossover Ethernet cable. 

 
 

4.2 Boot in “Install Mode” 
 
In order to upload the project data to the Iddero Home Server, you first now boot in “install mode”. For 
this, press and hold the “RESET / PRG” button for a few seconds. The Iddero Home Server will beep 
three times to acknowledge the request, and will automatically enter install mode (the unit also enters 
install mode automatically the first time it boots, or when no valid project data is found.) 
 
Once the boot process completes, the unit will beep twice, and the “STATUS” indicator will turn green 
and start to flash. 
 
 

4.3 Finding the Iddero Home Server 
 
The Iddero Home Server is preconfigured to obtain an IP address automatically using the DHCP 
protocol. DHCP is supported by almost every router and DSL modem, and should be available in most 
home and office networks. Thus in the majority of the cases, no additional configuration should be 
needed at this stage. 
 
In case you need to connect the Iddero Home Server to a network that does not provide a DHCP 
service (for example, when connecting directly to a PC or notebook with a crossover cable), the Iddero 
Home Server will automatically start with IP address 192.168.0.250, network mask 255.255.255.0. In 
this case, make sure that the IP address of the PC or notebook is in also in the 192.168.0.x range (for 
example, 192.168.0.201). 
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In order to find the current IP address of the Iddero Home Server, select Programming → Search for 
devices in the Iddero configuration software. A list of available devices will be shown, along with the IP 
address assigned to each one, and some additional information (serial number, firmware version, etc.) 
 
Also, the “Mode” column shows the current operating mode for each unit (“Install” for install mode, and 
“User” for normal operation). 
 
 

 
 
 

4.4 Commissioning 
 
In order to upload the project data to the Iddero Home Server, select Programming → Program... in 
the configuration software while the unit is in installation mode. 
 
The “Connect settings” dialog will pop up. Enter the IP address of the device, the installer user name 
and the installer password (default values: “instalador” / “knxinstall”) and click “Accept”. 
 
 

 
 
 
 
The commissioning process may take a few seconds to complete. Make sure you do not interrupt 
this process or otherwise disconnect or turn off the Iddero Home Server. Once the process is 
complete, press the “RESET / PRG” button, and the system will reboot with the new configuration. 
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4.5 Firmware Updates 
 
If you need to update the firmware of the Iddero Home Server, you can do so from the configuration 
software by selecting Programming → Update firmware. 
 
The software will first ask you to select a valid firmware update file (.bin file type). The “Connection 
settings” dialog will then pop up. The rest of the process is identical to the commissioning process. 
 
It is critical that you do not interrupt the operation or otherwise disconnect or turn off the Iddero 
Home Server during the update process. If the firmware update process is interrupted, the unit could 
be left in a locked state and may need to be returned to factory for repair. 
 
 

4.6 STATUS LED indicator 
 
The “STATUS” LED indicator at the top of the Iddero Home Server shows the current status of the 
device, according to the following table: 
 
 
STATUS LED indicator Device status 
Off The unit is off 
Heartbeat: LED flashes briefly in 
red two times per second 

The unit is booting 

Flashing green 
(150 ms green / 1 s off) 

The unit is ready in install mode 

Fixed color 
(red / green / yellow) 

The unit is ready and operating normally. The actual LED color depends on 
the application status; please refer to the user manual for more information 

Slow flashing red 
(1 s red / 1s off) 

A non-recoverable error occurred; the unit is not operative 

 
 
 

4.7 Restoring default settings 
 
The “DEFAULTS” button in the Iddero Home Server lets you restore certain settings to their default 
values. This is a recessed button; use a small pointed object such as a paperclip to push it. 
 
 

Restoring network settings to factory defaults 
 
This procedure restores network settings to factory defaults (DHCP). 
 

• (Recommended) Boot in install mode 
• Press and hold the DEFAULTS button 
• Press RESET / PRG briefly without releasing the DEFAULTS button. 
• The Iddero Home Server will start to emit short warning beeps. Do not release the DEFAULTS 

button yet. 
• After five seconds, the unit will emit a long beep. The network settings have been restored to 

factory defaults. Changes will be effective after rebooting. 
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Restoring user settings to default values 
 
This procedure restores user settings (user interface language, time schedules, scenes, access 
codes, etc.) to the values defined in the configuration project. 
 

• Boot normally (do not boot in install mode) 
• Once the unit is operating normally, press and hold the DEFAULTS button 
• The Iddero Home Server will start to emit short warning beeps. Do not release the DEFAULTS 

button yet. 
• After five seconds, the unit will emit a long beep. User settings have been restored to the 

values defined in the configuration project. 
 
 

4.8 Final network configuration 
 
Using DHCP for automatic IP address configuration simplifies the Iddero Home Server configuration 
and commissioning process. However, IP addresses obtained over DHCP are typically dynamic, and 
can change over time. This may confuse end users. 
 
To avoid this problem, we recommend that a static IP address is used in the final configuration of the 
Iddero Home Server. There are two ways to achieve this: 
 

1. Configure the DHCP server (typically the router or DSL modem) so that the same IP address 
is always assigned to the Iddero Home Server. This is typically called “DHCP reservation”. 

 
2. Configure the Iddero Home Server manually to use a static IP address. You can do this by 

disabling the DHCP function through the “Network settings” menu in the Iddero Home Server 
web based user interface. However, if the Iddero Home Server is installed on a network with a 
running DHCP service, you will still need to make sure that the selected IP address is outside 
of the address range managed by the DHCP server. 

 
In both cases you will need to check or modify the configuration of your DHCP server. The exact 
procedure depends on the device that is acting as a DHCP server; please refer to the documentation 
supplied by the manufacturer for additional information. 


