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1 Getting Started with VC Web 

VC Web is an extension of Visucontrol that will enable the user to access their VisuControl project 
that runs in the HMI panel over HTTP protocol through a web browser.  
 
VC Web will allow the user to access the VisuControl project in the panel via a PC, Tablet or a Mobile 
device from anywhere in the world. 

1.1 Assumptions 

 
We also assume that you have a basic understanding of PCs, Microsoft Windows, the type of network 
environment in which you will run the application and the browsers used by the devices from which 
you’ll be accessing VC Web pages. 
 
You may need Wifi capabilities if you want to work with iPad or that kind of a tablet to access the VC 
Web pages. 



Technical Manual VC Web 

Edition: 0612 
Technical Manual VisuControl Web 

 
5 

 

2 Supported Browsers/Platforms 

2.1 PC  

VC Web works well in all modern web browsers. The following are the browsers that we mainly focus 
as far as the browser compatibility is concerned. 
 

 Mozilla Firefox 3.6+ 
 Microsoft Internet Explorer 9+ 
 Apple Safari 5+ 
 Google Chrome 6+ 

 
 
 
 
 
 
 
 

2.2 Tablets 

 iOS 4.1+ - Mobile Safari 
 Android 2.1+ - Android Webkit 

 

 

2.3  Mobile / Smartphones 

 iOS 4.1+ - Mobile Safari 
 Android 2.1+ - Android Webkit 
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3 VisuControl Studio with VC Web 

3.1 VisuControl  

 
You need a VisuControl with VC Web feature in it to make VC Web work correctly. You can determine 
whether the VisuControl installed in your PC supports VC Web feature by clicking on File menu and 
check whether it has an Export Web Project menu item in it. Refer Figure 1 for more details. 
 

 
 
Figure 1 
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4 VC Web Compatible Items 

4.1 Supported Widgets 

VC Web now supports the following widgets in it. In other words the VisuControl projects that involve 
the following widgets will work correctly. 
 
 

 Label 
 Multiline Text 
 Numeric Fields 
 Buttons  
 Hotspot Buttons 
 Horizontal / Vertical Sliders 
 Gauge / Needle 
 Images 
 Multistate Images 
 Indicators (Lights) 
 Date/Time 
 Bar Graphs 
 Segmented Bar Graphs 
 Message widget 
 Knobs 
 Shapes 

4.2 Supported Actions 

VC Web currently supports the following VisuControl actions in it. 
 

 HomePage 
 LoadPage 
 NextPage 
 PrevPage 
 LastVisitedPage 
 WriteTag 
 StepTag 
 SetBit 
 ToggleBit 
 ShowDialog 
 CloseDialog 
 LaunchBrowser 
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4.3 Tag Attachments 

VC Web supports Tag attachments on widget’s properties and will work as expected.  
 
But at the moment it does not support that kind of tag attachment, which changes the range of the 
widget at runtime. For example a tag attached to a Slider or Bar Graph’s min or max property that 
updates the min or max values dynamically does not work in VC Web at the moment. 
 
Tags can be attached to properties like Value, Visible, Enable Animation, etc. based on the 
requirement. 
 
A widget’s value can be attached to another widget’s property (ies), if needed. This is based on the 
properties of a widget supported in VC Web. The most commonly maintained property of a widget is 
its value property. 

4.4 XForm Support 

VC Web supports the following XForm functionalities. 
 

 Scaling 
 Offset 
 ColorPalette 
 BitIndex 

 
The ColorPalette functionality now works with selected widgets like Buttons, Image, Bar graph, etc 
and with their Fill and Background Color properties. In other words only image based ColorPalette is 
now supported. 

4.5 Supported Widget Events 

The events support both VisuControl native actions as well as the ones based on JavaScript that are 
compatible with VC Web. Refer the section 4.2 and 4.7 for more information about the native actions 
as well as the JavaScript API supported by VC Web. 
 
VC Web can handle multiple actions mentioned in any of the below furnished events. 
 

 OnMousePress Event  
 OnMouseRelease Event 
 OnDataUpdate Event 

 

4.6 Supported Page Events 

The events support both VisuControl native actions as well as the ones based on JavaScript that are 
compatible with VC Web. Refer the section 4.2 and 4.7 for more information about the native actions 
as well as the JavaScript API supported by VC Web. 
 
VC Web can handle multiple actions mentioned in any of the below furnished events. 
 

 OnActivate Event 
 OnDeactivate Event 
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4.7 Supported JavaScript API 

VisuControl offers a set of JavaScript API through, which you can manipulate widgets, tag values, etc. 
Using these API, events mentioned in sections 4.5 and 4.6 can be handled to accomplish your 
requirements. 
 
At the moment VC Web supports a small subset custom JavaScript API supported by VisuControl.  
VC Web currently supports the following JavaScript API’s in it 
 

 getTag 
 setTag 
 getProperty 
 setProperty 
 getWidget 
 getProject 

4.8 Template Support 

VC Web works well with pages that use templates. The VC Web pages, when it accesses via browser 
it will be loaded in the browser based on the template used by the page in VisuControl. 
 
VC Web will function correctly if the page uses a template or not. 

4.9 Keypad support 

Numeric widgets, with a mode Read/Write or Write only supports a provision through which the 
user can insert new values into the widget/tag from the browser.  
 
This feature uses the keyboard of the device the user use, in other words there is no custom keypad 
to insert the value. 
 
The user can Click on the Numeric widget that can accept value, which will show a textbox in which 
the new value can be inserted.  
 
After inserting the value the user can either press Enter key / Enter key equivalent in touch devices 
or the user can click on the Save button shown below the text box to make the newly inserted value 
permanent. Only meaningful numbers will be accepted during the save process anything else will be 
ignored and will not result in a value change.  
 
The user can cancel the data insertion at any point by Clicking the Cancel button.  Please refer 
Figure 2 for more details. 
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Figure 2 

4.10 Dialog Pages 

VC Web supports Dialog pages. You can show them and close them based on the requirement via 
the ShowDialog and CloseDialog actions.  
 
Known limitations of Dialog Pages are:  
 

 They are not movable unlike the one supported by VisuControl Runtime  
 They can’t be positioned at a place. 
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5 Limitations of VC Web Compatible Widgets 

As VC Web is still in its infancy and there are some known issues that may experience while using VC 
Web 
 

 Widget rotation is not supported 
 Custom font in iPad has some issues. 
 Horizontal Slider reverse mode yet to support 
 Vertical Slider reverse false mode yet to support 
 Static Optimization of Page should be enabled if you encounter issues while generating the 

page background image, do this if applicable 
 Shape widgets at the moment acts as images ie you may not change the look and feel of it by 

attaching tag(s) on its UI based properties in your project. 
 Colorpalette XForm works only with selected widgets like Buttons, Images, Bar graph, etc 
 Widget properties based tag attachment may not work on all allowed properties by 

VisuControl 
 Dialog pages in VC Web supports only modal dialogs. 
 Dialog page sin VC Web does not support the Runtime positioning and are not movable 
 Round Bar Button widget is not supported in VC Web 
 The reflection of tag value updation made at the HMI panel at the browser will come with a bit 

delay ie the browser will get the updated value when it request data from the server. There 
may have a bit delay. 



Technical Manual VC Web 

Edition: 0612 
Technical Manual VisuControl Web 

 
12 

 

6 Limitations of VC Web compatible Page Events 

 Currently Page’s OnDataUpdate event is not supported. 
 Currently Dialog page’s OnDataUpdate event is not supported. 
 Currently Template page’s OnDataUpdate event is not supported. 
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7 Generate VC Web Pages for Using 

7.1 VisuControl Project 

You can use any of your existing VisuControl project or can make a new project to start using  
VC Web. If you are working with an existing project anything in the project which is not compatible 
with VC Web will be ignored. You can create a new project using VisuControl if you prefer to avoid 
using an existing project. You must load a project in VisuControl to start things. 

7.2 Exporting Pages 

This is the first step in which we create VC Web pages is generating VC Web pages for the 
VisuControl project/dialog pages. These generated pages will work on the browser. 
 
You can export the currently loaded VisuControl project pages by clicking on File -> Export Web 
Project.  
 
Refer Figure 3 for more details 
 

 
 
Figure 3 
 
You’ll have to Export the pages each time after you make any changes in the project to make the 
changes reflect in the VC Web page in the browser. You’ll have to reload/refresh the VC Web if you 
have the page opened in the browser. 
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7.3 Select Pages to Export 

While exporting pages you can export all the project pages or a number of the project pages based on 
your requirements. 
 
By default for the first time all the pages (project and dialog pages) will be ready to export. This can 
be changed if and only if you want. 
 

 
 
Figure 4 
 
After clicking the File -> Export Web Project menu item VisuControl will show a dialog similar that of 
Figure 4. 
 
VC Web support 3 platforms generally: Web, Tablets and Phone. You can either select all these 
platforms for your pages while exporting ie the selected pages will be compatible in all three 
platforms. 
 
You can uncheck the checkbox under specific platform(s) for a page if you don’t need a page in a 
specific platform 
 
This is the place where you can select or unselect all the pages that you’d like to be in VC Web. 
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7.4 Pages for Specifc VC Web Platforms 

You can design VisuControl project pages in such a way that the page fits for specific platform that 
the VC Web supports. This is suitable for designing pages for Mobile/Smartphone devices.  
 
The viewport area of the Mobile/Smartphone devices is limited and may not fit a big page in it. So you 
can design some special pages suitable for this platform. 
 
Also you can create a different set of pages, which will have all the functionality of the normal project 
pages but will be really suitable for the VC Web purpose and can export them to VC Web. In other 
words the look and feel of the pages in the VC Web will not be similar that of the one in HMI panel but 
they’ll be similar in a functional point of view. So that you can design the pages for the platforms Web, 
Mobile or Tablet like the way you want and still be able to manipulate the project that is running in 
HMI panel. 
 

7.5 Setting VC Web Homepage 

Setting a Homepage for your VC Web app is important. Either you can use first page of the project as 
the Homepage or you can select another page manually as your VC Web Homepage or you can set 
different Homepages for Web, Tablets and Mobile platforms. It is all based upon your actual 
requirement. 
 

 
 
Figure 5  
 
In the Figure 5 you can see that the Page named Home is acting as the Homepage for all 3 platforms. 
If you want to change it to something else then you just need to click on the inactive Home icon 
shown under the platform (marked as a red box in Figure 5 and marked with an arrow). After the click 
the inactive Dome icon this dialog will be like Figure 6. 
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Figure 6 
 
You can see that the Homepage of the Web platform is Lighting page now. 
 
Like this you’ll be able to designate a different Homepages for each of the 3 platforms if the situation 
demands that. 

7.6 Start VC Web Pages Export 

After selecting the pages and a Homepage for each platform you can click on OK Button to start the 
actual VC Web page generation. Refer Figure 7 for more details 
 
At this point you can cancel the page export by clicking the Cancel button or the Close button of the 
dialog. Refer Figure 7 for more details 
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Figure 7 
 
Once you press the OK button, Refer Figure 7, VisuControl will start generating VC Web pages for 
each of the selected project pages and will show a progress bar during the process. Refer Figure 8 
 

 
 
Figure 8 
 
After the page generation the progress bar shown in Figure 8 will be removed from the studio 
interface and you can proceed to download the project to your desired target. 
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8 Download Project 

After generating the VC Web pages the next step is to download the project to the desired target, 
assuming that the Touchpanel is already in running mode with the correct Runtime in it. 
 
You can start the project download by clicking on the Run -> Download To Target menu item. Refer 
Figure 9 
 

 
 
Figure 9 
 
You can start the download process even by clicking the ‘Download To Target’ Toolbar button. Refer 
Figure 10 for more details 
 

 
Figure 10 
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This will show the Download To Target dialog box from which you can select your target device’s IP 
address and can start the download process. Refer Figure 11 for more details 
 

 
 
Figure 11 
 
Click on the Download button shown in Figure 11 to start the download process. 
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9 Loading VC Web Pages from Browser 

After the successful download of VisuControl project to your target device your VC Web pages are 
ready for access.  
 
You can open any one of the VC Web compatible browser specified in section 2.1, 2.2 or 2.3 and type 
the IP address of your HMI Panel or the Server in which the Runtime is running with the project 
loaded in it and press enter or hit any button that simulates an Enter key click in the device that you 
use. 
 
You’ll now see the VC Web Login page in your screen. Refer Figure 12 
 

 
 
Figure 12 
 
Figure 12 shows the login page from PC using Mozilla Firefox browser 
 
Figure 13 shows the login page from iPad using Mobile Safari browser. 
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Figure 13 
 
Enter the User name and Password and click on Sign In button or click Enter key or Tap on the key 
equivalent to the Enter key in touch devices. 
 
Now you’ll be redirected to the Homepage of the platform you’ve selected during the page export. 
Refer Figure 14, which shows a sample project page in VC Web 
 

 
Figure 14 
 
After you reach the Homepage of your project in VC Web you can use it the same way you do it in 
your HMI Panel or your target. 
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10 VC Web and Server Crash / Disconnection 

10.1 Determine Server Crash/Disconnection in VC Web 

The server that runs in the HMI panel may crash or disconnect from the network. This directly results 
in non-accessibility of service for VC Web as it will not be able to communicate with the server for 
getting data from it as well as writing the data to it. 
 
VC Web has a provision that constantly checks whether there is any disconnection from the server. If 
there is a disconnection VC Web will show a toolbar on top of the VC Web page loaded in the 
browser with a disconnected icon in it. Refer Figure 15 in which the disconnected icon is marked 
using a red arrow. 
 

 
 
Figure 15 
 

10.2 VC Web Action Execution during Server Crash/Disconnection 

Any Server bound operation will result in a failure during a Server crash/disconnection. The changes 
may reflect in VC Web pages but it’ll have no effect in the Server as it is no longer live.  
 
For example assume that you have some StepTag actions associated with some Button widgets in 
the page. A Server crash/disconnection has occurred and the disconnection icon is visible that shown 
in Figure 15. At this point you click on the button and start the StepTag action. The action will execute 
correctly and reflect the change in VC Web but the final step of this action is to write the new value to 
the Server, which will result in a failure as the Server is not live. 
 
So next time server comes online the fields that are using the Server bound values in the VC Web 
page will be rolled back to the values from the Server. 
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10.3 Restart of Server from a Crashed/Disconnected state 

This will affect only if you have some VC Web page opened in your device that shows the 
disconnected icon at the moment.  
 
At this state when the Server restarted your page will show a modal login dialog, refer Figure 16 – 
taken from Mozilla Firefox browser, through which you can insert the user credentials and complete 
the login process. 
 
After a successful login process the current page will be shown and the disconnected icon and the 
toolbar will be removed from the screen. 
 
The page will be back to the ready state on which you can perform the operation as you need. 
 

 
 
Figure 16 
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11 Modal Login Dialog in VC Web Page 

When you work with VC Web you’ll notice that at times a modal login dialog will be shown, refer 
Figure 17. 
 
This will happen when any of the following condition is true  
 

 User session timeout occur  
 Explicitly removing all the browser cookies  
 Removing the cookie from  will result in showing this modal login dialog. 

 
The modal login dialog will help you to perform the login process while you are in a VC Web page 
without going back to the initial login page.  
 
For example if you are working with a project that has large number pages in it. Assume that you are 
in a middle page. You have reached here by executing LoadPage action lots of time using the page 
widget (Button). Now due to any of the above cited reason the user session timeout occurs. Now you 
need to perform the login if we try to go back the initial login page you may have to execute the 
LoadPage actions lot of times to get back to the current page. Modal login dialog will help you to 
complete your login process in a much simpler manner so that after the login process you’ll remain on 
the current page itself without going to any other page. 
 

 
 
Figure 17 
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12 Browser Settings 

12.1 Enable JavaScript 

VC Web is entirely depends upon JavaScript. If your device browser has JavaScript disabled then VC 
Web will not work correctly. 
 
By default browser comes with enabled JavaScript. But if you have disabled JavaScript in the past 
make sure you turned it on before accessing VC Web page. 

12.2 Accept HTTP Cookies 

In order to make VC Web work correctly in your browser, your browser should be able to accept 
HTTP Cookies.  
 
If your browser can’t accept cookies then change your browser settings in such a way that it can 
accept cookies. 
 
By default the browsers accepts cookies and you need not change this settings unless you have 
made an explicit change in this setting earlier. 
 
Section 12.1 explains how you can change your browser settings (in Windows) so that it can accept 
Cookies. You can skip this section if your browser accepts cookies. 

12.2.1 Enable Cookies in Mozilla Firefox 

 Click Tools -> Options. 
 Click Privacy in the top panel. 
 Set "Firefox will:" field to Use custom settings for history. 
 Check the box next to "Accept cookies from sites" to enable cookies. 
 Click OK. 

12.2.2 Enable Cookies in Microsoft Internet Explorer 

 Open Control Panel.  
 Double-click the Internet Options icon.  
 Select the Privacy tab. 
 Click Advanced.  
 Select "Override automatic cookie handling" under the "Cookies" section in the Advanced 

Privacy Settings window. 
 Select the "Accept" or "Prompt" option under "First-party Cookies". 
 Select the "Accept" or "Prompt" option under "Third-party Cookies." (If you select the 

"Prompt" option, you'll be asked for approval every time a website attempts to send you a 
cookie.)  

 In the Internet Options window, click OK to exit. 
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12.2.3 Enable Cookies in Google Chrome 

 Click the Tools icon near the address bar. 
 Select Settings. 
 Click the Under the Hood tab. 
 Click Content settings in the "Privacy" section. 

 Select Allow local data to be set to allow both first-party and third-party cookies. If you only 
want to accept first-party cookies, check the box next to "Block all third-party cookies 
without exception."  

12.2.4 Enable Cookies in Apple Safari 

 Go to the Edit drop-down menu. 
 Select Preferences. 
 Click Privacy in the top panel. 
 In Block cookies section Select the first radio button with value, ‘From third parties and 

advertisers’. This means to reject cookies from advertisers and from “third parties”—
websites other than those you open. This might help prevent certain advertisers from storing 
cookies on your computer. 

  
 
 
 
 
 


